the nvidia proprietary drivers don't work on @elementary 6.0 because it's based on the 20.04.3 HWE stack which canonical doesn't officially release for another week or so

(at least I think that is the reason)

my computer is struggling with nouveau

Join Pack

@elementary
copied from my github comment:

I got into a weird situation where nvidia drivers were installing properly for the 5.11.0-27 linux packages but grub wasn't updating to show that I could boot 5.11.0-27, it would only show 5.11.0-25. I did a sudo grub-install and rebooted, and my UEFI froze trying to load grub, but going into UEFI settings and manually booting "ubuntu" got me into grub where I could boot 5.11.0-27 with the nvidia driver properly loaded

1/2

@elementary
copied form my github comment:

I will note that part of this debugging process initially involved me running sudo prime-select nvidia and sudo nvidia-xconfig to no avail before I realized the kernel version issue, so it's possible that those commands also helped lead me to this current working state.

2/2

Sign in to participate in the conversation
asonix.dog

I just recreated oops